Announcement: Be excellent to each other.


Caravel Forum : Caravel Boards : The Site : Are Special Characters Sometimes Failing to be Displayed Properly? (Sorry if this has already been posted about)
New Topic New Poll Post Reply
Poster Message
navithmastero
Level: Smitemaster
Avatar
Rank Points: 553
Registered: 01-03-2012
IP: Logged
icon Are Special Characters Sometimes Failing to be Displayed Properly? (+1)  
I was looking back through some of the posts I had made and I've noticed that those containing a '£' sign are displaying a � (replacement character) indicating they cannot be displayed. I also read a post before where all of the commas were like this too. Is anyone else having a similar problem?

This isn't a browser issue btw. Tried in both FF and Chrome.

-nm

____________________________
Member of the Snake Appreciation Society

One of your local HAs.

My stuff:
Click here to view the secret text

02-12-2015 at 05:43 PM
View Profile Send Private Message to User Send Email to User Show all user's posts High Scores This architect's holds Quote Reply
rman
Level: Smiter
Avatar
Rank Points: 371
Registered: 09-24-2007
IP: Logged
icon Re: Are Special Characters Sometimes Failing to be Displayed Properly? (+1)  
Looks like that recently happened to all posts containing non-ASCII characters. The non-ASCII characters got replaced with U+FFFD REPLACEMENT CHARACTER in the database. So it can’t be a browser issue, the posts themselves contain U+FFFD. You can see that for yourself if you edit one of the “broken” posts and replace U+FFFD with the original character; the original character will then appear properly.

Now, what caused that in the first place? Probably some database maintenance operation (perhaps a few days ago, when the forum was rather unstable?). Admins may give more details.

____________________________
Click here to view the secret text

Best quote ever (TSS ending spoiler):
Click here to view the secret text

02-12-2015 at 06:02 PM
View Profile Send Private Message to User Send Email to User Show all user's posts Quote Reply
Insoluble
Level: Smitemaster
Avatar
Rank Points: 1636
Registered: 09-04-2014
IP: Logged
icon Re: Are Special Characters Sometimes Failing to be Displayed Properly? (+1)  
It was brought up in this thread:

http://forum.caravelgames.com/viewtopic.php?TopicID=39330&page=0#392609

From the discussion on that thread, it sounds like Schick is aware of the issue and working on figuring it out.

____________________________
Links to neat forum tools that I always have trouble finding:
Click here to view the secret text

02-12-2015 at 06:23 PM
View Profile Send Private Message to User Send Email to User Show all user's posts High Scores This architect's holds Quote Reply
navithmastero
Level: Smitemaster
Avatar
Rank Points: 553
Registered: 01-03-2012
IP: Logged
icon Re: Are Special Characters Sometimes Failing to be Displayed Properly? (+1)  
Ah okay, sorry for re-raising it then. Thanks Insoluble.

-nm

____________________________
Member of the Snake Appreciation Society

One of your local HAs.

My stuff:
Click here to view the secret text

02-12-2015 at 06:25 PM
View Profile Send Private Message to User Send Email to User Show all user's posts High Scores This architect's holds Quote Reply
New Topic New Poll Post Reply
Caravel Forum : Caravel Boards : The Site : Are Special Characters Sometimes Failing to be Displayed Properly? (Sorry if this has already been posted about)
Surf To:


Forum Rules:
Can I post a new topic? No
Can I reply? No
Can I read? Yes
HTML Enabled? No
UBBC Enabled? Yes
Words Filter Enable? No

Contact Us | CaravelGames.com

Powered by: tForum tForumHacks Edition b0.98.8
Originally created by Toan Huynh (Copyright © 2000)
Enhanced by the tForumHacks team and the Caravel team.