Announcement: Be excellent to each other.


Caravel Forum : DROD Boards : Bugs : Input oddities in Linux / JtRH (Updated Jan 8th)
New Topic New Poll Post Reply
Poster Message
Pekka
Level: Master Delver
Rank Points: 263
Registered: 09-19-2007
IP: Logged
icon Input oddities in Linux / JtRH (0)  
I'm playing the Linux version of Journey to the Rooted Hold on a new Ubuntu 16.10 install. It does a few strange things with input that the newer DROD games do not. Well, two strange things to be exact.

1) Repeat input when entering a new room.

Let's say I walk north to enter an new room to the north of the current one. It repeats the move north command on first entering the second room. If I press R to restart the room, it does not automatically repeat it again, but restarts without doing anything else.

The same works in all directions. It always makes one move in the same direction as used in entering the room. I end up just pressing R every time I enter a room, so it's not a major issue.

2) Repeat move, but not turning, when regaining window focus.

First I make any walking move. Then I click outside the game running in windowed mode so it loses focus. Then I click back in the window. It shows the walking move again.

Now I do the same with a sword turn. It doesn't show it repeating.

This also happens if I use the title bar to move the window around. It does not happen if the move kills me, for example by triggering a bomb with my sword.

This is the JtRH Linux version downloadable from Caravel. I tried this with both the Unity and Xfce window managers. It does not happen with either of TCB or TSS demos, which I just now quickly verified. (It was easier to install the demos instead of the full games to test this one thing.)

The first issue with the automatic move is a small annoyance, and I'd be happy to get rid of it. Can anyone replicate it on Linux? Can anyone tell me of a configuration with Ubuntu 16.10 that does not exhibit it?

P.S. I own the digital copies on both GOG and Caravel. I wanted to try downloading and installing the game for Caravel to see how it works this way. I don't think there is a significant difference between the two, though.

P.P.S. If you reopen the tab in Firefox from which you downloaded one of the games, it counts that as another download. That's why it says for me I've used two downloads of JtRH even though I only downloaded it just a few days ago. I don't think this will be a problem, because I also have the games on GOG :)

UPDATE: I switched to Fedora 25, and the room-entering bug went away. I am using the same downloaded installer and the Xfce window manager, so the problem has something to do with Ubuntu 16.10 on my computer. Unfortunately, since I installed Fedora in Ubuntu's place, I cannot test it any more.

I still get the repeated move effect after losing window focus, but that is not a problem at all. I merely wonder why it happens for walking movement, but not turning movement ;)

[Last edited by Pekka at 01-08-2017 04:12 PM]
01-07-2017 at 06:31 PM
View Profile Send Private Message to User Show all user's posts High Scores This architect's holds Quote Reply
New Topic New Poll Post Reply
Caravel Forum : DROD Boards : Bugs : Input oddities in Linux / JtRH (Updated Jan 8th)
Surf To:


Forum Rules:
Can I post a new topic? No
Can I reply? No
Can I read? Yes
HTML Enabled? No
UBBC Enabled? Yes
Words Filter Enable? No

Contact Us | CaravelGames.com

Powered by: tForum tForumHacks Edition b0.98.8
Originally created by Toan Huynh (Copyright © 2000)
Enhanced by the tForumHacks team and the Caravel team.